Windows 8 и утечка памяти

Когда мне жалуются на "тормоза" компьютера первое на что я смотрю - загрузка процессора, второе - использование оперативной памяти. Практика показала, что при использовании компьютером\сервером более чем 70% ОЗУ могут возникать всякого рода ошибки\"тормоза". Если при 70% занятой памяти это еще наблюдается не часто\явно, то про превышении 80% работа за таким компьютером становиться не комфортной.

Именно такие "тормоза" и начались на одном из компьютеров с ОС Windows 8. Занято было было более 80% ОЗУ из 8 ГБ, но при этом не было понятно кто съел "лишние" 4 ГБ, приложений было запущено не так уж и много, происходила "утечка памяти".

Читать о утечке памяти в Windows 8

Как охладить ноутбук

Как охладить ноутбук? Несколько действенных методов

Охладить ноутбук можно следующими достаточно простыми методами:

  • Чистка от пыли
  • Ограничение максимальной нагрузки процессора
  • Охлаждающая подставка
  • Медные радиаторы

Рано или поздно ноутбук начинает жужжать своими кулерами все громче и громче, все больше и больше греться и в крайне запущенных случаях выключаться от перегрева. Также стоит знать, что чем выше температура нагрева техники - тем меньше она прослужит. То есть даже когда нет явного перегрева, более низкие температуры для техники будут полезней.

Читать как охладить ноутбук.

Windows 8: как установить .Net Framework 3.5

Нашему программисту понадобился Framework 3.5 на новом компьютере с Windows 8 x64 bit. Вроде бы тривиальная задача, но мне пришлось повозится.

При попытке установить .Net Framework 3.5 возникала ошибка

Не удалось установить следующий компонент: .NET Framework 3.5 (включает .NET 2.0 и 3.0)

Системе Windows не удалось подключиться к Интернету, для загрузки необходимых файлов. Проверьте подключение и попробуйте еще раз, нажав кнопку "Повторить".

Код ошибки: 0x800F0906

Ошибка .Net Framework 3.5 на Windows 8

Читать о том, как решить ошибку с установкой .Net Framework 3.5 в Windows 8

Хостинг eurobyte.ru (Евробайт): обзор

В этой записи будет обзор хостинга eurobyte.ru. Недавно со мной связались представители хостинга eurobyte и попросили написать обзор про их хостинг. Я попросил предоставить рекламный текст, с условием что укажу во вступлении "это реклама". Их такой вариант не устроил, представители хостинга Евробайт хотели именно честный обзор с моим мнением и критикой, и готовы были за это заплатить существенно больше (так как мнение мое и времени на это будет потрачено больше), чем за публикацию их хвалебного текста.

Честно говоря этим они меня удивили и заработали себе первый плюс - они настолько уверены в качестве своих услуг, что даже после того, как я сказал что мой обзор будет без подхалимства, со здравой аргументированной критикой и предоплатой, их ответ был краток - "нас все устраивает".

Ну раз просили, тогда получайте =)

Читать обзор о хостинге eurobyte

EventID 13: Automatic certificate enrollment for the local system failed

Ошибка EventId 13

Заметил в логах на вторичном контролере домена вот такую надоедливую ошибку (засоряла логи с интервалом раз в несколько часов):

Event Source: AutoEnrollment
Event ID: 13
Description:
Automatic certificate enrollment for local system failed to enroll for one Domain Controller certificate (0x80070005). Access is denied.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Читать как избавиться от ошибки

Exchange 2003: восстановление баз данных

W41MPI810uQ[1]

На прошлой неделе у меня проявился "глюк" из-за которого база Exchange начала расти и съедать место. Через 5 дней, утром в прошлый понедельник, база отъела все доступные 75 ГБ свободного пространства на диске "C", это как раз и продемонстрировано на рисунке. Свободного места на системном диске нет, а значит все сервисы полноценно работать не могут, в том числе и почтовый.

В этих экстремальных условиях я размонтировал базы данных Exchange, почистил диск С и попытался снова подмонтировать базы, но в ответ получил ошибку. Значит придется восстанавливать целостность баз данных.

Читать о восстановлении баз данных Exchange 2003

ESEUTIL: Unable to find the callback library jcb.dll

ESEUTIL - это утилита с помощью которой можно дефрагментировать базы Exchange, проверить их целостность или восстановить их работоспособность если с ними возникли проблемы.

У меня во время работы с этой утилитой начала выскакивать ошибка:

Unable to find the callback library jcb.dll (or one of its dependencies).

При том, что файл jcb.dll никуда не пропал и находился там, где ему положено: в папке C:\Program Files\Exchsrvr\bin\

Как решить проблему с ESEUTIL

Панель вебмастеров: ссылки на ваш сайт - нет данных

В четверг вечером, 17-го числа, заметил что в google панели вебмастеров в разделе "Поисковый трафик - Ссылки на ваш сайт" вместо отображения количества ссылок и ссылающихся доменов отображается надпись "нет данных".

Читать дальше. Запись может быть интересна только тем, кто попал в эту же ситуацию

KES 10 и Windows 8: Ошибка установки

На работе купили новый компьютер вместе с ОС Windows  8.

Установил windows 8 professional 64 bit, поставил драйвера, накатил обновления, пришла очередь устанавливать антивирус Касперского (Kaspersky Endpoint Security), тут то и начались проблемы.

В этой записи я сэкономлю время тех, кто столкнулся с ошибкой установки KES10 на Windows 8 и подскажу в чем кроется проблема.

Читать дальше

Feedburner: отключение utm_source=feedburner в URL

Заприметил что в индекс иногда добавляются страницы в URL которых присутствует "?utm_source=feedburner", большинство таких страниц сразу попадают в дополнительный индекс, так как являются дублями.

Виновен в этом Fedburner. Если зайти в rss-ленту от Feedburner и кликнуть на какую-либо запись, можно увидеть что к адресу поста добавиться много лишнего текста.

Чтобы это исправить нужно зайти в свой "feedburner - analyze - configure stats" и убрать галочку напротив "Tracks clicks as a traffic source in Google Analytics".  Тогда к адресу записи этот текст не будет добавляться.

Чекбокс "Tracks clicks as a traffic source in Google Analytics" позволяет анализировать в Google Analytics трафик из Feedburner, именно для этого и добавляются к URL дополнительные параметры. Я этой опцией не пользуюсь и она мне не нужна, видимо раньше я ее случайно включил.